DSpace 7 Installation

    0.00 0.00 0.0 USD

    2,500.00

    This combination does not exist.

    Add to Cart

    DSpace 7 Installation

    Installation Overview
    Backend Installation
    Installing the Backend (Server API)
    Backend Requirements
    UNIX-like OS or Microsoft Windows
    Java JDK 11 (OpenJDK or Oracle JDK)
    Apache Maven 3.3.x or above (Java build tool)
    Apache Ant 1.10.x or later (Java build tool)
    Relational Database (PostgreSQL or Oracle)
    PostgreSQL 11.x, 12.x or 13.x (with pgcrypto installed)
    Oracle 10g or later
    Apache Solr 8.x (full-text index/search service)
    Servlet Engine (Apache Tomcat 9, Jetty, Caucho Resin or equivalent)
    (Optional) IP to City Database for Location-based Statistics
    Git (code version control)

    Frontend Installation
    Apache HTTPD, Nginx, etc.
    Installing the Frontend (User Interface)
    Frontend Requirements
    UNIX-like OS or Microsoft Windows
    Node.js (v12.x or v14.x)
    Yarn (v1.x)
    PM2 (or another Process Manager for Node.js apps) (optional, but recommended for Production)

    DSpace 7 Installation
    DSpace 7.0 Installation
    DSpace 7.1 Installation
    DSpace 7.2 Installation


    30-day money-back guarantee
    Free Shipping in U.S.
    Buy now, get in 2 days

    This is a preview of the recently viewed products by the user.
    Once the user has seen at least one product this snippet will be visible.

    Recently viewed Products