DSpace Upgrading to a newer version

We will port those customizations you wish to keep and create additional ones. Your users can keep using the full functionality of the old version until the scheduled rollout of your newly upgraded DSpace.

These instructions are valid for any of the following upgrade paths: Upgrading ANY prior version (1.x.x, 3.x, 4.x or 5.x) of DSpace to DSpace 6.x (latest version) This section describes how to upgrade a DSpace installation from one version to the next. Subject: DSpace Upgrading. Details of the differences between the functionality of each version are given in the Version History section. In the notes below [dspace] refers to the install directory for your existing DSpace installation, and [dspace-source] to the source directory for DSpace 6.x. Whenever you see these path references, be sure to replace them with the actual path names on your local system.

Update Prerequisite Software (as necessary)

DSpace 6.x requires the following versions of prerequisite software:

  • Java 7 or 8 (Oracle or OpenJDK)
  • Apache Maven 3.0.5 or above
  • Apache Ant 1.8 or above
  • Database
    • PostgreSQL 9.4 or above (with pgcrypto installed), OR
    • Oracle 10g or above
  • Tomcat 7 or above

If you’re using a theme based on Mirage 2, you will need Maven 3.1 or above.  If you are building with mirage2.deps.included=false (more information at https://github.com/DSpace/DSpace/tree/dspace-6_x/dspace-xmlui-mirage2) then the following dependencies may need to be updated as well:

  • node, to version 6 or above
  • npm, to version 3.10.8 or above

DSpace Upgrading from 5.x to 6.x

In the notes below [dspace] refers to the install directory for your existing DSpace installation, and [dspace-source] to the source directory for DSpace 6 Whenever you see these path references, be sure to replace them with the actual path names on your local system.

DSpace Upgrading to a newer version

 

This post is also available in: İngilizce